2007-01-30

Carpetas _svn y radrails

La versión 1.0.3 de subclipse no se banca carpetas administrativas de svn con _svn. Pero la versión 1.0.4 sí. El problema es que RadRails (que es la customización de eclipse para programar sitios web con rails) viene con la versión 1.0.3.

Así que intenté hacer Help -> Update RadRails. Pero me dio un mensaje de error: RadRails (0.7.2) requires plug-in "org.eclipse.core.runtime (2.1.0)", or later version.

Buscando en la net no encontré ninguna solución fácil a este problema, así que me mandé a mirar como está armado RadRails y toqué un descriptor de eclipse para que no me de más ese error. Eclipse está compuesto por "features" que tienen "plugins". Y la configuración de RadRails exige en un feature que sea mejor o igual que otro, como indica el error.

Navegando un toque por los descriptores de las features encontré un candidato. En la línea 234 del archivo RadRails\feature\org.radrails.feature_0.7.2\feature.xml dice:

<import plugin="org.eclipse.core.runtime" version="2.1.0" match="greaterOrEqual">

Lo cambié a <import plugin="org.eclipse.core.runtime"> y Help -> Update RadRails empezó a funcar. Hice update, instalé subclipse 1.0.4 y listo el pollo.

Bueno, ahora tengo soporte para svn en RadRails 0.7.2 en Windows :D.

4 comentarios:

Anónimo dijo...

Gracias maestro... me ahorraste horas de buceo...

Gustavo Romero dijo...

Aurelio, muy buena esa ayuda. Hace meses que tenia que saltarme la actualizacion por causa de ese mismi error.
Gracias!!

Anónimo dijo...

Fantastico
LAAAAA solucion!

be

vitores dijo...

Muy hábil.

Funcionó,
muchas gracias.